This project is read-only.

Problem with reloading memcached

Jul 24, 2010 at 6:31 AM

I have created an asp.net application to test memcached:

http://spaces.tencube.com/varun/MemcachedSelfTest.zip

The application basically creates a session, writes a value to it and then reads it back.

However, for the following use case. It does not work!

1. Hit the page - it works

2. Now stop memcached service

3. Hit the page again

4. As expected, we get a 500 Internal Server Error

5. Now start the memcached service

6. Hit the page again

 

Expected: The client would recover after a while.

Observer: The client does not recover. There is some kind of deadlock. Hitting the page makes the request eventually timeout.

 

I tried with the older version of Enyim.Cached. When that didn't work, I tried the newer version at:

http://github.com/enyim/EnyimMemcached

 

I had to make a small change to the Increment and Decrement functions.

 

However, the new version does not work either for this test case.

This library is excellent, but I cannot use it in any production code because of this error :-(

I hope someone can help me resolve my issue!!!

 

Regards,

Varun.