This project is read-only.

Cannot get Cache provider to work (Vista)

Jun 16, 2008 at 12:39 PM
Hi,

I followed the simple steps outlined in your 1.1 Beta-based walkthrough document.

I am trying to use DistCache in a Windows Forms Application. Unfortunately, I cannot get this simple task working.
When I use 127.0.0.1 the Add operation never comes back - and if I use my machine's name I get an exception ("Invalid address specified");

Any idea?

Thanks,
Christian
Jun 16, 2008 at 2:47 PM
Hi,
First thing I would try is to check connectivity with the memcached server. Windows Firewall might have blocked it.

This can be done using the telnet client in windows

:> telnet 127.0.0.1 11211
 and then type "stats" to get memcached stats.

If you don't have telnet installed please follow the following link Installing the Telnet client on Vista

Also try to run your windows with the option "Run as Administrator"

Hope this would help.
Thanks,
Fahad





ChristianWeyer wrote:
Hi,

I followed the simple steps outlined in your 1.1 Beta-based walkthrough document.

I am trying to use DistCache in a Windows Forms Application. Unfortunately, I cannot get this simple task working.
When I use 127.0.0.1 the Add operation never comes back - and if I use my machine's name I get an exception ("Invalid address specified");

Any idea?

Thanks,
Christian



Jun 16, 2008 at 4:31 PM
Hi Fahad,

thanks for your quick reply.
I already did all of what you said before posting :) So, unfortunately, this did not help - I can connect via telnet, and even if I run my client app with elevated privs it does not work.
Veeery strange... and obviously a showstopper.

Thanks,
-Christian

Jun 16, 2008 at 5:05 PM
Edited Jun 16, 2008 at 5:11 PM
After debugging it seems to hang in PooledSocket.ReadLine() ...

Therefore I opened a topic over at enyim.com's client lib site:
http://www.codeplex.com/EnyimMemcached/Thread/View.aspx?ThreadId=29730

-Christian